Author Topic: Coolant sensor message - 1997 ZJ 4.0  (Read 4832 times)

SteveTheFolkie

  • Full Member
  • **
  • Posts: 170
  • To live is to fly, all alone and high
    • View Profile
    • Steves music site
Coolant sensor message - 1997 ZJ 4.0
« on: June 21, 2014, 11:52:23 am »
Intermittent issue (man, they're just the greatest!) on my '97 ZJ - every once in a while the "coolant sensor failed" message will appear on the information panel in front of the shifter - I'll get an annoying "beep beep" and an orange square will appear within the outline of the hood on the display.  Coolant level is fine, temperature runs at a steady 190F no matter the outside temp - think this is a "real actual" problem or just a bad connector somewhere in the wiring harness?

Cheers

Steve

PaulW

  • Jr. Member
  • *
  • Posts: 64
  • Dunno what goes here.
    • View Profile
Re: Coolant sensor message - 1997 ZJ 4.0
« Reply #1 on: June 21, 2014, 07:15:18 pm »
I think that usually indicates the coolant level sensor in the overflow bottle.  I believe those sensors are under $20. 
04 TJ, bastard lift, 33's, winch, bumpers, dents and scratches and it's not even paid for yet!  Paul Wilks.

SteveTheFolkie

  • Full Member
  • **
  • Posts: 170
  • To live is to fly, all alone and high
    • View Profile
    • Steves music site
Re: Coolant sensor message - 1997 ZJ 4.0
« Reply #2 on: July 08, 2014, 09:57:01 pm »
Belated thanks - replaced the sensor and the message is gone

Cheers

Steve

PaulW

  • Jr. Member
  • *
  • Posts: 64
  • Dunno what goes here.
    • View Profile
Re: Coolant sensor message - 1997 ZJ 4.0
« Reply #3 on: July 10, 2014, 10:24:58 pm »
Glad it was an easy fix.  I had some death wobble I cured today with $400 in parts at AutoZone.
04 TJ, bastard lift, 33's, winch, bumpers, dents and scratches and it's not even paid for yet!  Paul Wilks.